关于Apache Struts 2远程代码执行漏洞的风险提示

发布时间: 2020-12-10 15:24:59 访问量:

    近日,国家信息安全漏洞库(CNNVD)收到关于Apache Struts2 S2-061远程代码执行漏洞(CNNVD-202012-449、CVE-2020-17530)情况的报送。成功利用漏洞的攻击者可以在目标系统执行恶意代码。Apache Struts 2.0.0 - 2.5.25版本均受此漏洞影响。目前,Apache官方已经发布了版本更新修复了该漏洞。建议用户及时确认产品版本,尽快采取修补措施。

一、漏洞介绍

    Apache Struts2是美国阿帕奇(Apache)软件基金会下属的Jakarta项目中的一个子项目,是一个基于MVC设计的Web应用框架。漏洞源于Apache Struts2在某些标签属性中使用OGNL表达式时,因为没有做内容过滤,导致攻击者传入精心构造的请求时,可以造成OGNL二次解析,执行指定的恶意代码。

二、危害影响

    成功利用漏洞的攻击者可以在目标系统执行恶意代码。Apache Struts 2.0.0 - 2.5.25版本均受此漏洞影响。

三、修复建议

    目前,Apache官方已经发布了版本更新修复了该漏洞。建议用户及时确认产品版本,尽快采取修补措施。Apache官方更新链接如下:

    http://struts.apache.org/download.cgi




以上文章来源于CNNVD